$re = '/^(\s*)(^|$)/m';
$str = '
aaaa
aaa ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;