const regex = /^(?!mailto)(?:https?|ftp):\/(?:\/?(?:[.#@?=]?[a-z0-9\u00a1-\uffff]+)+)+[.]?(?:png|jpe?g|gif)$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!mailto)(?:https?|ftp):\\\/(?:\\\/?(?:[.#@?=]?[a-z0-9\\u00a1-\\uffff]+)+)+[.]?(?:png|jpe?g|gif)$', 'img')
const str = `Allowed
http://hoogle.com.jpeg
ftp://foogle.com/bla.gif
https://localhost/test.jpg
http://127.0.0.1/test.jpg
Not Allowed
http://hoogle.com
not a url
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}