re = /^(?!mailto)(?:https?|ftp):\/(?:\/?(?:[.#@?=]?[a-z0-9\u00a1-\uffff]+)+)+[.]?(?:png|jpe?g|gif)$/im
str = 'Allowed
http://hoogle.com.jpeg
ftp://foogle.com/bla.gif
https://localhost/test.jpg
http://127.0.0.1/test.jpg
Not Allowed
http://hoogle.com
not a url
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end