package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^is engulfed in a swarm of deadly insects.$`)
var str = `is engulfed in a swarm.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}