re = /^is engulfed in a swarm of deadly insects.$/m
str = 'is engulfed in a swarm.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end