$re = '/^is engulfed in a swarm of deadly insects.$/m';
$str = 'is engulfed in a swarm.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);