package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.\d+\.\d+)`)
var str = `Здравствуйте! Столкнулся с проблемой фильтрации данных отправляемых в тг бота. В боте нужно заполнить анкету, все данные отправляются в бд.. например с полем диапазона цен я решил с помощью if,else и >,<,==. Но этот способ не подходит под все поля, например поле ввода даты, нужно чтобы принимались даты только в формате 10.10.2020, если формат ввода не совпадает, должно выдать ошибку`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}