// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+\.\d+\.\d+)").unwrap();
let string = "Здравствуйте! Столкнулся с проблемой фильтрации данных отправляемых в тг бота. В боте нужно заполнить анкету, все данные отправляются в бд.. например с полем диапазона цен я решил с помощью if,else и >,<,==. Но этот способ не подходит под все поля, например поле ввода даты, нужно чтобы принимались даты только в формате 10.10.2020, если формат ввода не совпадает, должно выдать ошибку";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}