import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+\\.\\d+)";
final String string = "Здравствуйте! Столкнулся с проблемой фильтрации данных отправляемых в тг бота. В боте нужно заполнить анкету, все данные отправляются в бд.. например с полем диапазона цен я решил с помощью if,else и >,<,==. Но этот способ не подходит под все поля, например поле ввода даты, нужно чтобы принимались даты только в формате 10.10.2020, если формат ввода не совпадает, должно выдать ошибку";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}