import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-z]|\\d+)(?:\\.\\d+)*\\.?\\s*(?:\\([A-Z]\\.\\d+(?:\\.[A-Z]\\.\\d+)*\\)\\s*)?";
final String string = "c.2 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "b.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "a.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "1. Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "1.2 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
+ "1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
+ "5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
+ "5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}