$re = '/^(?:[a-z]|\d+)(?:\.\d+)*\.?\s*(?:\([A-Z]\.\d+(?:\.[A-Z]\.\d+)*\)\s*)?/m';
$str = 'c.2 Employed population below international poverty line, by sex and age (%) Age: 15+
b.1 Employed population below international poverty line, by sex and age (%) Age: 15+
a.1 Employed population below international poverty line, by sex and age (%) Age: 15+
1. Employed population below international poverty line, by sex and age (%) Age: 15+
1.2 Employed population below international poverty line, by sex and age (%) Age: 15+
1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;