import Foundation
let pattern = #"^(?:[a-z]|\d+)(?:\.\d+)*\.?\s*(?:\([A-Z]\.\d+(?:\.[A-Z]\.\d+)*\)\s*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
c.2 Employed population below international poverty line, by sex and age (%) Age: 15+
b.1 Employed population below international poverty line, by sex and age (%) Age: 15+
a.1 Employed population below international poverty line, by sex and age (%) Age: 15+
1. Employed population below international poverty line, by sex and age (%) Age: 15+
1.2 Employed population below international poverty line, by sex and age (%) Age: 15+
1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)