import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?-.*?-.*?-\\s+(.*)";
final String string = "005 - 0000 - 2310 - Storage - Summer\n"
+ "007 - 0000 - 1610 - Legal - Criminal Law\n"
+ "007 - 0000 - 8921 - Legal - Civil - Zoning\n"
+ "002 - 0000 - 2410 - Planning\n"
+ "123 - 0000 - 2510 - Finance/Corporate\n"
+ "008 - 0000 - 2520 - Legal - Technical Patents\n"
+ "321 - 0000 - 2610 - Clients & Storage";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}