// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*?-.*?-.*?-\s+(.*)").unwrap();
let string = "005 - 0000 - 2310 - Storage - Summer
007 - 0000 - 1610 - Legal - Criminal Law
007 - 0000 - 8921 - Legal - Civil - Zoning
002 - 0000 - 2410 - Planning
123 - 0000 - 2510 - Finance/Corporate
008 - 0000 - 2520 - Legal - Technical Patents
321 - 0000 - 2610 - Clients & Storage";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}