import re
regex = re.compile(r".*?-.*?-.*?-\s+(.*)")
test_str = ("005 - 0000 - 2310 - Storage - Summer\n"
"007 - 0000 - 1610 - Legal - Criminal Law\n"
"007 - 0000 - 8921 - Legal - Civil - Zoning\n"
"002 - 0000 - 2410 - Planning\n"
"123 - 0000 - 2510 - Finance/Corporate\n"
"008 - 0000 - 2520 - Legal - Technical Patents\n"
"321 - 0000 - 2610 - Clients & Storage")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")