using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\d*(\d)\1)[10]+\b";
string input = @"no binary numbers here 3434.
Hey friend this is a 1.
Those are 1001, 1010, 1011, 1100, 1101
This is a long value 1010101010 and this one as well 1010101010101011
0 + 0 is a also a 0.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}