$re = '/\b(?!\d*(\d)\1)[10]+\b/m';
$str = 'no binary numbers here 3434.
Hey friend this is a 1.
Those are 1001, 1010, 1011, 1100, 1101
This is a long value 1010101010 and this one as well 1010101010101011
0 + 0 is a also a 0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);