$re = '/var\d+(?:(?!var\d).)*?secondVar/s';
$str = 'var12.1
a
a
dsa
88
123!!!
secondVar12.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);