import re
regex = re.compile(r"var\d+(?:(?!var\d).)*?secondVar", flags=re.DOTALL)
test_str = ("var12.1\n"
"a\n"
"a\n"
"dsa\n\n"
"88\n"
"123!!!\n"
"secondVar12.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")