re = /var\d+(?:(?!var\d).)*?secondVar/
str = 'var12.1
a
a
dsa
88
123!!!
secondVar12.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end