#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ESP\d{1,2}\K.+"
Local $sString = "ESP100" & @CRLF & _
"ESP10234234" & @CRLF & _
"ESP78hello"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)