const regex = /^ESP\d{1,2}\K.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ESP\\d{1,2}\\K.+', 'gm')
const str = `ESP100
ESP10234234
ESP78hello`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);