re = /^ESP\d{1,2}\K.+/m
str = 'ESP100
ESP10234234
ESP78hello'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result