#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<n>[-+]?\d+(?:\.\d+)?)" & @CRLF & _
" (?<a>\s*[-+*\/]\s*)" & @CRLF & _
" (?<g>\((?:(?&n)|(?&g))(?&a)(?:(?&n)|(?&g))\))" & @CRLF & _
")" & @CRLF & _
"^(?&g)$"
Local $sString = "(14.0 + 46.0)" & @CRLF & _
"((5.0 - 50.0) - 15.0)" & @CRLF & _
"(15.0 - (5.0 - 50.0))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")