import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<n>[-+]?\\d+(?:\\.\\d+)?)\n"
+ " (?<a>\\s*[-+*\\/]\\s*)\n"
+ " (?<g>\\((?:(?&n)|(?&g))(?&a)(?:(?&n)|(?&g))\\))\n"
+ ")\n"
+ "^(?&g)$";
final String string = "(14.0 + 46.0)\n"
+ "((5.0 - 50.0) - 15.0)\n"
+ "(15.0 - (5.0 - 50.0))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}