package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<n>[-+]?\d+(?:\.\d+)?)
(?<a>\s*[-+*\/]\s*)
(?<g>\((?:(?&n)|(?&g))(?&a)(?:(?&n)|(?&g))\))
)
^(?&g)$`)
var str = `(14.0 + 46.0)
((5.0 - 50.0) - 15.0)
(15.0 - (5.0 - 50.0))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}