using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(class\s?=\s?)\""([\d\w\s]*)(\brow\b)([\d\w\s]*)\""";
string input = @"class=""foo_bar bar row test""
class=""row""
class=""narrow""
class=""rowdy""
class="" rowdy ""
class=""flex-mt90 foo bar row"" row
class="" foo bar row test """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}