import re
regex = re.compile(r"(class\s?=\s?)\"([\d\w\s]*)(\brow\b)([\d\w\s]*)\"", flags=re.MULTILINE)
test_str = ("class=\"foo_bar bar row test\"\n"
"class=\"row\"\n"
"class=\"narrow\"\n"
"class=\"rowdy\"\n"
"class=\" rowdy \"\n"
"class=\"flex-mt90 foo bar row\" row\n"
"class=\" foo bar row test \"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")