const regex = /(class\s?=\s?)\"([\d\w\s]*)(\brow\b)([\d\w\s]*)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(class\\s?=\\s?)\\"([\\d\\w\\s]*)(\\brow\\b)([\\d\\w\\s]*)\\"', 'gm')
const str = `class="foo_bar bar row test"
class="row"
class="narrow"
class="rowdy"
class=" rowdy "
class="flex-mt90 foo bar row" row
class=" foo bar row test "`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}