# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:bs )?(?:en )?(?:np )?is[o0]\s+[-\d]+:)(.+:)?(\d{4}(?:\(e\))?)/$1$3/img;t' <<< "ISO 11784:1996/Amd.2:2010(E)
ISO 11784:2010(E)
ISO 11784:2010
ISO 11784-2-3-4:1996/Amd.2:2010(E)
ISO 11784-2-8-7:2010(E)
ISO 11784-5-120-78949-56-789:2010
BS EN ISO 11784:1996/Amd.2:2010(E)
EN ISO 11784:2010(E)
IS0 11784:2010
EN NP IS0 11784-2-3-4:1996/Amd.2:2010(E)
BS IS0 11784-2-8-7:2010(E)
EN NP ISO 11784-5-120-78949-56-789:2010
"