import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:bs )?(?:en )?(?:np )?is[o0]\\s+[-\\d]+:)(.+:)?(\\d{4}(?:\\(e\\))?)";
final String string = "ISO 11784:1996/Amd.2:2010(E)\n"
+ "ISO 11784:2010(E)\n"
+ "ISO 11784:2010\n"
+ "ISO 11784-2-3-4:1996/Amd.2:2010(E)\n"
+ "ISO 11784-2-8-7:2010(E)\n"
+ "ISO 11784-5-120-78949-56-789:2010\n"
+ "BS EN ISO 11784:1996/Amd.2:2010(E)\n"
+ "EN ISO 11784:2010(E)\n"
+ "IS0 11784:2010\n"
+ "EN NP IS0 11784-2-3-4:1996/Amd.2:2010(E)\n"
+ "BS IS0 11784-2-8-7:2010(E)\n"
+ "EN NP ISO 11784-5-120-78949-56-789:2010\n";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}