# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*\b\d{2}\.\d{2}.*dollars)((\b\d{2}\.\d{2})(?:.*)(dollars)(?:.*))/$2 $3/gm;t' <<< "78.00600.00 dollars test"