import re
regex = re.compile(r"^(?=.*\b\d{2}\.\d{2}.*dollars)((\b\d{2}\.\d{2})(?:.*)(dollars)(?:.*))", flags=re.MULTILINE)
test_str = "78.00600.00 dollars test"
subst = "$2 $3"
result = regex.sub(subst, test_str)
if result:
print(result)