using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\b\d{2}\.\d{2}.*dollars)((\b\d{2}\.\d{2})(?:.*)(dollars)(?:.*))";
string substitution = @"$2 $3";
string input = @"78.00600.00 dollars test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}