import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/tld\\.example\\.com(.*?)ref=testetghe";
final String string = "icon-459822882 attributeIcon-1499443538\" focusable=\"false\" height=\"100%\" role=\"img\" \n"
+ " width=\"100%\"><use xlink:href=\"#icon-clipboard\"></use></svg><dl class=\"itemAttribute-1164924913\"><dd \n"
+ " class=\"attributeValue-3783238563\"><a class=\"attributeLink-387024144\" rel=\" noopener noreferrer\" \n"
+ " href=\"https://tld.example.com/en/main?id=325235231763265&ref=testetghe\" \n"
+ " title=\"Opens in a new window.\" target=\"_blank";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}