import re
regex = re.compile(r"https:\/\/tld\.example\.com(.*?)ref=testetghe")
test_str = ("icon-459822882 attributeIcon-1499443538\" focusable=\"false\" height=\"100%\" role=\"img\" \n"
" width=\"100%\"><use xlink:href=\"#icon-clipboard\"></use></svg><dl class=\"itemAttribute-1164924913\"><dd \n"
" class=\"attributeValue-3783238563\"><a class=\"attributeLink-387024144\" rel=\" noopener noreferrer\" \n"
" href=\"https://tld.example.com/en/main?id=325235231763265&ref=testetghe\" \n"
" title=\"Opens in a new window.\" target=\"_blank")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")