re = /https:\/\/tld\.example\.com(.*?)ref=testetghe/
str = 'icon-459822882 attributeIcon-1499443538" focusable="false" height="100%" role="img"
width="100%"><use xlink:href="#icon-clipboard"></use></svg><dl class="itemAttribute-1164924913"><dd
class="attributeValue-3783238563"><a class="attributeLink-387024144" rel=" noopener noreferrer"
href="https://tld.example.com/en/main?id=325235231763265&ref=testetghe"
title="Opens in a new window." target="_blank'
# Print the match result
str.match(re) do |match|
puts match.to_s
end