// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m);((?:[a-zA-Z]+ )+)(.*?);").unwrap();
let string = "<pnr>0240978840</pnr>;Amplificator AD8622ARMZ;<upa>1</upa>
<pnr>0273101670</pnr>;Power Management LT1236BIS8-10;<upa>1</upa>
<pnr>0299801750</pnr>;Power Management LT1175IS8-5;<upa>3</upa>
<pnr>0233201780</pnr>;Amplificator LT1498CS8;<upa>4</upa>";
let substitution = "<kwd>$1</kwd><adt>$2</adt>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}