#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+@.+\..+"
Local $sString = "@" & @CRLF & _
"hi@" & @CRLF & _
"@hola" & @CRLF & _
"@hola.com" & @CRLF & _
"mkyong" & @CRLF & _
"Abc@example.com" & @CRLF & _
"user+mailbox/department=shipping@example.com" & @CRLF & _
"юзер@екзампл.ком" & @CRLF & _
"θσερ@εχαμπλε.ψομ" & @CRLF & _
"伊昭傑@郵件.商務" & @CRLF & _
""Joe.\\Blow"@example.com" & @CRLF & _
""Fred Bloggs"@example.com" & @CRLF & _
"hi@" & @CRLF & _
"mkyong@.com.my" & @CRLF & _
"mkyong123@gmail.a" & @CRLF & _
"mkyong123@.com" & @CRLF & _
"mkyong123@.com.com" & @CRLF & _
".mkyong@mkyong.com" & @CRLF & _
"mkyong()*@gmail.com" & @CRLF & _
"mkyong@%*.com" & @CRLF & _
"mkyong..2002@gmail.com" & @CRLF & _
"mkyong.@gmail.com" & @CRLF & _
"mkyong@mkyong@gmail.com" & @CRLF & _
"mkyong@gmail.com.1a" & @CRLF & _
""user1@hotmail.com; user2@gmail.com"" & @CRLF & _
""user1@hotmail.com; user2@gmail.com; user3@company.com"" & @CRLF & _
""User Display Name user3@company.com"" & @CRLF & _
""user4 @company.com"" & @CRLF & _
"List of Valid Email Addresses" & @CRLF & _
"" & @CRLF & _
"email@example.com" & @CRLF & _
"firstname.lastname@example.com" & @CRLF & _
"email@subdomain.example.com" & @CRLF & _
"firstname+lastname@example.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@example.com" & @CRLF & _
"1234567890@example.com" & @CRLF & _
"email@example-one.com" & @CRLF & _
"_______@example.com" & @CRLF & _
"email@example.name" & @CRLF & _
"email@example.museum" & @CRLF & _
"email@example.co.jp" & @CRLF & _
"firstname-lastname@example.com" & @CRLF & _
"much.”more\ unusual”@example.com" & @CRLF & _
"very.unusual.”@”.unusual.com@example.com" & @CRLF & _
"very.”(),:;<>[]”.VERY.”very@\\ "very”.unusual@strange.example.com" & @CRLF & _
"plainaddress" & @CRLF & _
"#@%^%#$@#$@#.com" & @CRLF & _
"@example.com" & @CRLF & _
"Joe Smith <email@example.com>" & @CRLF & _
"email.example.com" & @CRLF & _
"email@example@example.com" & @CRLF & _
".email@example.com" & @CRLF & _
"email.@example.com" & @CRLF & _
"email..email@example.com" & @CRLF & _
"あいうえお@example.com" & @CRLF & _
"email@example.com (Joe Smith)" & @CRLF & _
"email@example" & @CRLF & _
"email@-example.com" & @CRLF & _
"email@example.web" & @CRLF & _
"email@111.222.333.44444" & @CRLF & _
"email@example..com" & @CRLF & _
"plainaddress" & @CRLF & _
"#@%^%#$@#$@#.com" & @CRLF & _
"”(),:;<>[\]@example.com" & @CRLF & _
"just”not”right@example.com" & @CRLF & _
"this\ is"really"not\allowed@example.com" & @CRLF & _
"@example.com" & @CRLF & _
"Joe Smith <email@example.com>" & @CRLF & _
"email.example.com" & @CRLF & _
"email@example@example.com" & @CRLF & _
".email@example.com" & @CRLF & _
"email.@example.com" & @CRLF & _
"email..email@example.com" & @CRLF & _
"あいうえお@example.com" & @CRLF & _
"email@example.com (Joe Smith)" & @CRLF & _
"email@example" & @CRLF & _
"email@-example.com" & @CRLF & _
"email@example.web" & @CRLF & _
"email@111.222.333.44444" & @CRLF & _
"email@example..com" & @CRLF & _
"Abc..123@example.com" & @CRLF & _
"Abc..123@example.com" & @CRLF & _
"much.”more\ unusual”@example.com" & @CRLF & _
"very.unusual.”@”.unusual.com@example.com" & @CRLF & _
"very.”(),:;<>[]”.VERY.”very@\\ "very”.unusual@strange.example.com" & @CRLF & _
"email@example.com" & @CRLF & _
"firstname.lastname@example.com" & @CRLF & _
"email@subdomain.example.com" & @CRLF & _
"firstname+lastname@example.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@example.com" & @CRLF & _
"1234567890@example.com" & @CRLF & _
"email@example-one.com" & @CRLF & _
"_______@example.com" & @CRLF & _
"email@example.name" & @CRLF & _
"email@example.museum" & @CRLF & _
"email@example.co.jp" & @CRLF & _
"firstname-lastname@example.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")