using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+@.+\..+";
string input = @"@
hi@
@hola
@hola.com
mkyong
Abc@example.com
user+mailbox/department=shipping@example.com
юзер@екзампл.ком
θσερ@εχαμπλε.ψομ
伊昭傑@郵件.商務
""Joe.\\Blow""@example.com
""Fred Bloggs""@example.com
hi@
mkyong@.com.my
mkyong123@gmail.a
mkyong123@.com
mkyong123@.com.com
.mkyong@mkyong.com
mkyong()*@gmail.com
mkyong@%*.com
mkyong..2002@gmail.com
mkyong.@gmail.com
mkyong@mkyong@gmail.com
mkyong@gmail.com.1a
""user1@hotmail.com; user2@gmail.com""
""user1@hotmail.com; user2@gmail.com; user3@company.com""
""User Display Name user3@company.com""
""user4 @company.com""
List of Valid Email Addresses
email@example.com
firstname.lastname@example.com
email@subdomain.example.com
firstname+lastname@example.com
email@123.123.123.123
email@[123.123.123.123]
""email""@example.com
1234567890@example.com
email@example-one.com
_______@example.com
email@example.name
email@example.museum
email@example.co.jp
firstname-lastname@example.com
much.”more\ unusual”@example.com
very.unusual.”@”.unusual.com@example.com
very.”(),:;<>[]”.VERY.”very@\\ ""very”.unusual@strange.example.com
plainaddress
#@%^%#$@#$@#.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@example.web
email@111.222.333.44444
email@example..com
plainaddress
#@%^%#$@#$@#.com
”(),:;<>[\]@example.com
just”not”right@example.com
this\ is""really""not\allowed@example.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@example.web
email@111.222.333.44444
email@example..com
Abc..123@example.com
Abc..123@example.com
much.”more\ unusual”@example.com
very.unusual.”@”.unusual.com@example.com
very.”(),:;<>[]”.VERY.”very@\\ ""very”.unusual@strange.example.com
email@example.com
firstname.lastname@example.com
email@subdomain.example.com
firstname+lastname@example.com
email@123.123.123.123
email@[123.123.123.123]
""email""@example.com
1234567890@example.com
email@example-one.com
_______@example.com
email@example.name
email@example.museum
email@example.co.jp
firstname-lastname@example.com
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}