# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+@.+\..+"
test_str = ("@\n"
"hi@\n"
"@hola\n"
"@hola.com\n"
"mkyong\n"
"Abc@example.com\n"
"user+mailbox/department=shipping@example.com\n"
"юзер@екзампл.ком\n"
"θσερ@εχαμπλε.ψομ\n"
"伊昭傑@郵件.商務\n"
"\"Joe.\\\\Blow\"@example.com\n"
"\"Fred Bloggs\"@example.com\n"
"hi@\n"
"mkyong@.com.my\n"
"mkyong123@gmail.a\n"
"mkyong123@.com\n"
"mkyong123@.com.com\n"
".mkyong@mkyong.com\n"
"mkyong()*@gmail.com\n"
"mkyong@%*.com\n"
"mkyong..2002@gmail.com\n"
"mkyong.@gmail.com\n"
"mkyong@mkyong@gmail.com\n"
"mkyong@gmail.com.1a\n"
"\"user1@hotmail.com; user2@gmail.com\"\n"
"\"user1@hotmail.com; user2@gmail.com; user3@company.com\"\n"
"\"User Display Name user3@company.com\"\n"
"\"user4 @company.com\"\n"
"List of Valid Email Addresses\n\n"
"email@example.com\n"
"firstname.lastname@example.com\n"
"email@subdomain.example.com\n"
"firstname+lastname@example.com\n"
"email@123.123.123.123\n"
"email@[123.123.123.123]\n"
"\"email\"@example.com\n"
"1234567890@example.com\n"
"email@example-one.com\n"
"_______@example.com\n"
"email@example.name\n"
"email@example.museum\n"
"email@example.co.jp\n"
"firstname-lastname@example.com\n"
"much.”more\\ unusual”@example.com\n"
"very.unusual.”@”.unusual.com@example.com\n"
"very.”(),:;<>[]”.VERY.”very@\\\\ \"very”.unusual@strange.example.com\n"
"plainaddress\n"
"#@%^%#$@#$@#.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"email.@example.com\n"
"email..email@example.com\n"
"あいうえお@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@-example.com\n"
"email@example.web\n"
"email@111.222.333.44444\n"
"email@example..com\n"
"plainaddress\n"
"#@%^%#$@#$@#.com\n"
"”(),:;<>[\\]@example.com\n"
"just”not”right@example.com\n"
"this\\ is\"really\"not\\allowed@example.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"email.@example.com\n"
"email..email@example.com\n"
"あいうえお@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@-example.com\n"
"email@example.web\n"
"email@111.222.333.44444\n"
"email@example..com\n"
"Abc..123@example.com\n"
"Abc..123@example.com\n"
"much.”more\\ unusual”@example.com\n"
"very.unusual.”@”.unusual.com@example.com\n"
"very.”(),:;<>[]”.VERY.”very@\\\\ \"very”.unusual@strange.example.com\n"
"email@example.com\n"
"firstname.lastname@example.com\n"
"email@subdomain.example.com\n"
"firstname+lastname@example.com\n"
"email@123.123.123.123\n"
"email@[123.123.123.123]\n"
"\"email\"@example.com\n"
"1234567890@example.com\n"
"email@example-one.com\n"
"_______@example.com\n"
"email@example.name\n"
"email@example.museum\n"
"email@example.co.jp\n"
"firstname-lastname@example.com\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.