package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d*\.\d+\.\d+(?:-[a-zA-Z0-9]+)?$`)
var str = `1.2.40
1.0.0-SNAPSHOT
2.0.45-RC
3.10.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}