$re = '/^[1-9]\d*\.\d+\.\d+(?:-[a-zA-Z0-9]+)?$/m';
$str = '1.2.40
1.0.0-SNAPSHOT
2.0.45-RC
3.10.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);