const regex = /(([\w\s\d]+\s)(is the|is a|are the|are a|was)\s([\w\d\s\[\]\)\(,']+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([\\w\\s\\d]+\\s)(is the|is a|are the|are a|was)\\s([\\w\\d\\s\\[\\]\\)\\(,\']+))', 'g')
const str = `Hendrik Weber (born 1975), better known as Pantha du Prince, Panthel and Glühen 4 is a German producer, composer and conceptual artist for Electro, Techno, House, Minimal and Noise affiliated with Hamburg's Dial music label[1][2] and British label Rough Trade.[3]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}