use strict;
my $str = 'Hendrik Weber (born 1975), better known as Pantha du Prince, Panthel and Glühen 4 is a German producer, composer and conceptual artist for Electro, Techno, House, Minimal and Noise affiliated with Hamburg\'s Dial music label[1][2] and British label Rough Trade.[3]';
my $regex = qr/(([\w\s\d]+\s)(is the|is a|are the|are a|was)\s([\w\d\s\[\]\)\(,']+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}