#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)-(\w{3}?)-(\d{6}?)-(\w+?)-"
Local $sString = "80-pcc-000670-WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads/WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads-1551388618-res.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")