import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)-(\\w{3}?)-(\\d{6}?)-(\\w+?)-";
final String string = "80-pcc-000670-WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads/WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads-1551388618-res.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}