using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)-(\w{3}?)-(\d{6}?)-(\w+?)-";
string input = @"80-pcc-000670-WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads/WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads-1551388618-res.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}