using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""']).*\1(?![^\s])";
string input = @"""a'b""
""ab""
'ffg' ""hhh""
""
''
""'""
'acd"" 'gf
""Don't forget the @""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}