$re = '/\b[A-Z].*?\d{1,2}\.\d{1,2}\.\d{2,4}(?=\s+[A-Z]|$)/m';
$str = 'N678 à p. du 11.6.23 C+23.6.23 N−14.,24.7.23
N678 N−12.,13.12.22,18.,19.,31.1.,9.2.,7. au 10.,13. au 17.,20.,21.,22.,28.
au 31.3.,6.,13.,19.,20.4.,5.,8.5.23
N68 du 12.6. au 3.9.23 C+23.6.,15.8.23 N-18.,25.6.,2.,17. au 21.,23. au 28.,31.7.,3.,4.,7.,8.,9.,27.8.23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);